Linux下用pptp连接VPN服务器(下)

时间:2008-10-03 13:40:31  来源:第二电脑网上收集  作者:

  第二电脑网导读:8日);所以使用2.6内核版本的用户可以使用其更新软件。下面笔者会简单介绍一下安装方法。以Fedora Core 2 为例子:    1. 下载安装相关库文件    #wget  http://www.city-fan.org/ftp/contrib/drivers...
  正文: 图形前端pptpconfig程序:pptp-php-gtk已经停止更新(2003年12月18日);所以使用2.6内核版本的用户可以使用其更新软件。下面笔者会简单介绍一下安装方法。以Fedora Core 2 为例子:

    1. 下载安装相关库文件

    #wget  http://www.city-fan.org/ftp/contrib/drivers/pptp/libglade-0.17-19.fc6.i386.rpm 
    #wget http://www.city-fan.org/ftp/contrib/drivers/pptp/libglade-devel-0.17-19.fc6.i386.rpm
    #rpm –ivh libglade-devel-0.17-19.fc6.i386.rpm
    #rpm –ivh libglade-0.17-19.fc6.i386.rpm

    2. 安装DKMS 模块软件包

    #wget  http://www.city-fan.org/ftp/contrib/drivers/pptp/dkms-2.0.13-1.noarch.rpm
    #rpm --install dkms-2.0.13-1.noarch.rpm

    3. 下载安装、查看kernel_ppp_mppe 内核模块

    #wget   http://www.city-fan.org/ftp/contrib/drivers/pptp/kernel_ppp_mppe-1.0.2-3dkms.noarch.rpm
    #rpm --install kernel_ppp_mppe-0.0.4-2dkms.noarch.rpm
    #modprobe ppp-compress-18 && echo success
    success #应当显示success信息#

    4. 下载安装ppp软件包

    #wget   http://www.city-fan.org/ftp/contrib/drivers/pptp/ppp-2.4.4-1.2.fc2.i386.rpm
    #rpm --upgrade ppp-2.4.4-1.2.fc2.i386.rpm

    5.下载安装VPN客户端软件pptp-linux

    #wget  ftp://fr2.rpmfind.net/linux/sourceforge/p/pp/pptpclient/pptp-linux-1.5.0-1.i386.rpm
    #rpm --install pptp-linux-1.4.0-1.i386.rpm

    6. 下载安装辅助软件包

    #wget  http://www.city-fan.org/ftp/contrib/drivers/pptp/php4-pcntl-4.4.1-2.i386.rpm
    #wget http://www.city-fan.org/ftp/contrib/drivers/pptp/php4-pcntl-gtk-1.0.2-2.i386.rpm
    #rpm -ivh php4-pcntl-4.4.1-2.i386.rpm
    #rpm -ivh php4-pcntl-gtk-1.0.2-2.i386.rpm

    7.下载、安装前端GUI软件pptpconfig

    #wget  http://www.city-fan.org/ftp/contrib/drivers/pptp/pptpconfig-20060821-1.noarch.rpm
    #rpm -ivh pptpconfig-20060821-1.noarch.rpm

    8. 启动图形前端pptpconfig

    在命令行下使用命令“pptpconfig”即可启动启动图形前端。主要界面和2.4 内核版本介绍的基本相同。只是在Encryption(加密)选项如图1 。
 

图1在Encryption(加密)选项

    多出一个选项即:Refuse to Authenticate with EAP 〔refuse-eap〕拒绝EAP认证。
    linux下要用vpn会用到ppp,但似乎很难与windows作为服务器的vpn服务器沟通:
    先看看如何显示调试信息,这对找出问题的出处很有帮助。
    在 /etc/ppp/options.pptp里加入
    debug dump logfd 2 nodetach
    如果有 "Unsupported protocol rcvd [proto=xxxx]" 这样的错误,那么需要在options.pptp里加入这一句
    refuse-eap
    这个选项即对应以上配置文件的选项。

    其他方面图形前端2.6内核版本的pptpconfig和2.4 内核版本的设置是相同的这里就不赘述了。

Linux下用pptp连接VPN服务器(下)》由第二电脑网原创提供,转载请注明:http://www.002pc.com/master/College/Server/Linux/2008-10-03/657.html


关键字:

关于《Linux下用pptp连接VPN服务器(下)》文章的评论

站内搜索: 高级搜索

热门搜索: Windows style 系统 tr IP QQ CPU 安装 function 注册 if td